Fixing Solr Error: “TokenizerFactory is using deprecated 5.5.0 emulation. You should at some point declare and reindex to at least 6.0,‚Äč because 5.x emulation is deprecated and will be removed in 7.0”

If you upgrade to Solr 7, you can get this error:

TokenizerFactory is using deprecated 5.5.0 emulation. You should at some point declare and reindex to at least 6.0,​ because 5.x emulation is deprecated and will be removed in 7.0

I was able to fix this by updating the Lucene version in solrconfig.xml for the core:

7.0.0

To make this take effect, I unloaded the core, deleted the data, made the change, and re-indexed.